0

Somehow my Emacs always displays inline images by default, which is not what I want. I've tried the following but none of them worked:

  1. Add #+STARTUP: noinlineimages at the top of a file.
  2. Explicitly set org-startup-with-inline-images to nil, although it is nil by default.
  3. To rule out the possibility of a local variable somewhere, I created a file in /tmp/ and open it in Emacs. Still displaying inline image.

org-toggle-inline-images does work, but I want Emacs to stop displaying inline image at startup.

Emacs version: GNU Emacs 28.1 (build 1, x86_64-apple-darwin20.6.0, Carbon Version 164 AppKit 2022.6) of 2022-04-09

4
  • After starting up when images are visible, evaluate the relevant variable to see whether it is indeed nil. You can use C-h v or M-x eval-expression and type in the name of the variable. If the variable is non-nil, then something in your settings may be setting it afterwards.
    – lawlist
    Jun 23 at 5:19
  • 1
    I'm also running 28.1, just ran emacs -q and this is the behaviour I get (in-line images do not display by default). I suspect the culprit may be somewhere in your init.el.
    – randouser
    Jun 23 at 10:46
  • @lawlist It's nil. "Local in buffer .... Global value is the same."
    – Jordan He
    Jun 24 at 17:31

1 Answer 1

0

It turns out, it's because of the use of org-inline-pdf package, which executes (org-display-inline-images) every time you turn on org-inline-pdf-mode, and I have this mode bind to orgmode. My solution is to remove that line of code in org-inline-pdf.el.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.