When I type C-h r I get error:

Debugger entered--Lisp error: (error "Info file emacs does not exist") signal(error ("Info file emacs does not exist")) error("Info file %s does not exist" "emacs") Info-find-file("emacs")
Info-find-node("emacs" "Top") Info-goto-node("(emacs)")
info-setup("emacs" #) info("emacs")
info-emacs-manual() call-interactively(info-emacs-manual nil nil)

I am using Emacs 24.3 on Ubuntu 14.04. (I have installed package emacs24-common-non-dfsg.. )

4 Answers 4


That error is because the full documentation is not installed by default.

Solve it by installing emacs25-common-non-dfsg

# aptitude install emacs25-common-non-dfsg

Test it by trying,

C-h i h

It should now work.

  • 1
    It is interesting to know that GNU Free Documentation License (GFDL) is at odds with Debian Free Software Guidelines (DFSG). This is the reason why it is not included in the first place.
    – Lei Zhao
    Commented Jul 26, 2020 at 23:30
  • 1
    Update in 2023 - Ubuntu 22.04, installed Elisp docs with apt install emacs-common-non-dfsg. From packages.ubuntu.com/jammy/emacs-common-non-dfsg
    – ckhan
    Commented Dec 26, 2023 at 2:19

You have to set the correct path to the Emacs info files in the INFOPATH environment variable:

export INFOPATH=$INFOPATH:/usr/share/info/emacs-24

I found it easier to build Emacs from source: you get not only full Emacs documentation but also a more recent version, presently 27.1 instead of 26.3 (in Ubuntu 20.10).

Configure is straightforward because all the dependencies can be obtianed with: sudo apt-get build-dep emacs.

Add to $INFOPATH: /usr/local/share/info /usr/share/info/emacs /usr/share/info.

  • Ubuntu 20.10. The non-dfsg stuff does not exist in apt. Commented Nov 10, 2020 at 18:19

Just setting INFOPATH didn't solve it for me.

I'm running Debian 9.4 derived Bunsen Helium. Somehow, I didn't get info, or the Emacs info files installed. So:
Set INFOPATH in .bashrc:

export INFOPATH=/usr/share/info
export INFOPATH=$INFOPATH:/usr/share/info/emacs

Then installed info:

$ sudo apt-get install info

Then downloaded these gnu info files and installed them in directory /usr/share/info/emacs
(did it as root)

Finally, upgraded my emacs version (got me up to Emacs 25.2.2):

$ sudo apt-get install emacs  

Not sure if all this was the 'right' way to do it, but I'm tired of fooling with it...

  • 2
    Did you install the emacs25-common-non-dfsg package?
    – phils
    Commented Sep 24, 2018 at 10:37
  • Just tried it. Way easier than what I was doing. Seems to put the info files in: /usr/share/info/emacs-25. Still need Commented Sep 25, 2018 at 0:36
  • 2
    It's really unfortunate, but Debian sees certain usage of the GNU Free Documentation License as non-free by their own definitions, and consequently installs Emacs (and doubtless other packages) without the documentation (which of course is really a crucial component of the application). Which explains why it's in a separate package (and the non-dfsg suffix). Refer to linux.com/news/debian-decides-gnu-free-documentation-license
    – phils
    Commented Sep 25, 2018 at 0:47
  • Tried to edit my comment, but some stupid 5 minute limit just tossed it... Commented Sep 25, 2018 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.