I use emacs in -nw mode on a computer cluster, and was using Emacs v25. I asked my sys admin to install a newer version (27 or higher) because global-display-line-numbers-mode was apparently not supported before version 27.

My sys admin then apparently installed Emacs v28.1 through conda

Since then, whenever I start up emacs I get the following error message in *Messages*

Wrong type argument: filenamep, "/scratch2/software/anaconda/envs/emacs/share/info^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^\
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@/" [24 times]

The error message does not appear when invoking -Q nw or -q nw

What does this mean??

The computer cluster OS: Ubuntu 18.04 LTS

  • 1
    Do you see that if you start Emacs with emacs -Q -nw? If not, do you see it with emacs -q -nw? If the answers are no and yes, respectively, then contact the person who installed Emacs and defined the site-wide files. See the Emacs manual, node Initial Options.
    – Drew
    Jul 4, 2022 at 22:12
  • Each ^@ is probably a null byte. My first guess would be that there's a corrupted file behind that, because that string value is all kinds of wrong.
    – phils
    Jul 5, 2022 at 3:00
  • @phils I originally meant when I run emacs path/to/some/file. But I just tested just opening emacs without opening a file at the same time, and then it gives me that error as well. When I then open a file via C-x C-f it doesn't return any errors. So it is just when opening emacs! I've adjusted the opening post Jul 5, 2022 at 13:56
  • 1
    @Drew I do not see it if I start with -Q -nw and I also do not see it with -q -nw. So I'm guessing it must be related with loading ~/.emacs.d/init.el ? Jul 5, 2022 at 14:10
  • 1
    Note that commenting out your init file won't stop Emacs from initializing the package system and any ELPA packages you have installed (nor from loading default.el and site-start.el libraries, which would typically live elsewhere on the system; but I believe those are both loaded under -q so it sounds like those aren't the issue). You could try renaming your .emacs.d directory, and/or setting package-enable-at-startup to nil in early-init.el
    – phils
    Jul 6, 2022 at 13:54

1 Answer 1


I had the exact same problem and managed to fix it by setting INFOPATH in my .bashrc to the path that's causing the problem, so in OP's case that would be:

export INFOPATH=/scratch2/software/anaconda/envs/emacs/share/info

I'm still not sure where Emacs is getting the garbaged version of that path from, but this seems to override it.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.