0

This variable always returns to default value. I tried to 'erase configuration' & remove it from myinit.el. Have this in myinit.org:

(setq org-agenda-sorting-strategy (quote ((todo todo-state-up))))
2
  • You have lisp code in an org file? How is that supposed to influence what emacs does? Are you producing your init file by tangling the org file? How do you make emacs use myinit.el as its initialization file? What does myinit.el look like? In short, I have at least a dozen questions about what you are doing that are not described in your question.
    – NickD
    Jul 21 at 17:53
  • This is my /.emacs.d github.com/slk500/emacs.d I see this line (setq org-agenda-sorting-strategy (quote ((todo todo-state-up)))) in myinit.el
    – slk500
    Jul 21 at 18:48

1 Answer 1

1

The cause of the problem depends on how your emacs is deciding what it is using for initialization. We need more information to know that, but we can offer potential causes.

For example, looking at the init.el that you have listed in the comments, are you sure that the custom variables block isn't causing your settings for todo to be overwritten?

(custom-set-variables
 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
[...]
 '(org-agenda-sorting-strategy
   '((agenda habit-down time-up priority-down category-keep)
     (todo priority-down category-keep)
     (tags priority-down category-keep)
     (search category-keep)))
)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.