6

I get the following message when starting Emacs:

Warning (emacs): Unable to activate package `elpy'.
Required package `highlight-indentation-0.5.0' is unavailable
Warning (emacs): Unable to activate package `elpy'.
Required package `highlight-indentation-0.5.0' is unavailable
Warning (emacs): Unable to activate package `elpy'.
Required package `highlight-indentation-0.5.0' is unavailable

I then found this Q&A: Find elisp origin of warning

So I followed the accepted answer and added the following to the top of my .emacs file:

(setq debug-on-message "Unable to activate package `elpy'.")

and then restarted Emacs, but nothing happened. Was I supposed to fall into the debugger?

How can I find what specific line in my .emacs file trigger the warning?

  • 1
    This is happening during package activation, so it's not your init file's fault. Just install the missing package. – Malabarba Jan 11 '15 at 23:26
  • Thanks @Malarba. I have uninstalled these packages precisely because they are giving me problems, so what I want to do is find out what is loading them. – Amelio Vazquez-Reina Jan 12 '15 at 2:20
  • Elpy is loading it. As explained in the warning and in the (elpy) issue you linked. ;-) – Malabarba Jan 12 '15 at 2:55
4

This is happening during package activation, so it's not your init file's fault.

What's happening

The warning is telling you everything you need to know. elpy needs to load highlight-indentation, but the package's not installed.

What to do

Either

  • install the missing package
  • or delete elpy.
  • Is it possible to check if the specific package failed to be activated then install it automatically so I don't need to install it manually? – CodyChan May 4 '18 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.