0

I am using apheleia for buffer formatting.

I want to disable apheleia-mode for the Latex-mode. I have tried following solution but it did not help.

(defun jpk/org-mode-hook ()
 (company-mode -1))
(add-hook 'org-mode-hook 'jpk/org-mode-hook)

What I tried, which did not help:

(apheleia-global-mode +1)
(defun app/LaTeX-mode-hook ()
  (apheleia-global-mode -1))
(add-hook 'LaTeX-mode-hook 'app/LaTeX-mode-hook)

Is there any way to disable apheleia for a major mode like LaTeX-mode?

1 Answer 1

2

I would try disabling it locally with:

(apheleia-global-mode +1)
(defun app/LaTeX-mode-hook ()
  (apheleia-mode -1))
(add-hook 'LaTeX-mode-hook 'app/LaTeX-mode-hook)

Notice the change from (apheleia-global-mode -1) to (apheleia-mode -1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.