0

I'm trying emacs to create a simple .rst mode. I tyoe M-x rst-mode then I wrote a simple code then type

M-x compile (proposed 'make -k') I obtain this message and it doesn't compile -- mode: compilation; default-directory: "~/" -- Compilation started at Mon Aug 1 17:46:51

make -k

/bin/sh: sphinx-build: command not found make: *** [help] Error 127

Compilation exited abnormally with code 2 at Mon Aug 1 17:46:51

what does it mean?

Thank you

Renato

11
  • It means you need to install the program make. What system are you on?
    – NickD
    Aug 1 at 16:00
  • aaaah..I 'm on mac osx 14.5 what I've to do?
    – RenatoP
    Aug 1 at 16:26
  • ... except you only need to install make because that's what Emacs was expecting you to want to run (the default option) when you executed M-x compile. In other words, to be clear, you do not need to install make (unless you have some other reason). Aug 1 at 16:45
  • Emacs does not know how to "compile" a .rst file; you need to either configure it (by setting variable compile-command) or type in the command you want executed. Aug 1 at 16:48
  • ok. emacs don't know 'compile'. what I have to do to install it?
    – RenatoP
    Aug 1 at 17:01

2 Answers 2

0

finaly...it works! 1 - installed Docutil (https://docutils.sourceforge.io/README.html#gnu-linux-bsds-unix-mac-os-x-etc) 2 - M-x rst-compile obtain this messageCompile command: rst2html.py README.rst README.html press return and...

-*- mode: compilation; default-directory: "~/sphinx/" -*-
Compilation started at Tue Aug  2 11:38:56

rst2html.py   README.rst README.html

Compilation finished at Tue Aug  2 11:38:56

and now...obtaining a .pdf! (is it possible to obtain .pdf from inside emacs? How?)

0

SOLVED! (quite solved) I've finaly produced my pdf on emacs (C-c C-c C-p), but using linux. Finaly I've understand that the prob was not emacs, but it is python and utility of python!. So I've made my issue on another s.o. (Manjaro quite of Arch linux). here, a start from beginning and step by step...all goes well.

Thank you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.