3

when I view png images in Dired-mode there is no problem but when I try to view the thumbnail of it (C-t d), it fails and throws this error: could not create thumb of <filename>.

M-: of dynamic-library-alist returns these lists:

((xpm "libxpm.dll" "xpm4.dll" "libXpm-nox4.dll") (png "libpng16.dll" "libpng16-16.dll") (tiff "libtiff-5.dll" "libtiff3.dll" "libtiff.dll") (jpeg "libjpeg-9.dll") (gif "libgif-7.dll") (svg "librsvg-2-2.dll") (gdk-pixbuf "libgdk_pixbuf-2.0-0.dll") (glib "libglib-2.0-0.dll") (gobject "libgobject-2.0-0.dll") (gnutls "libgnutls-28.dll" "libgnutls-26.dll") (libxml2 "libxml2-2.dll" "libxml2.dll") (zlib "zlib1.dll" "libz-1.dll"))  

What fundamental point am I missing?

Notes:

  • Windows 7 32 bit
  • Emacs 24.4
  • 1
    Could it be you haven't got imagemagick installed? IIRC the thumbnails are created with the convert command it provides. – wasamasa Jan 12 '15 at 10:26
  • @wasamasa is it a requirement? I will try to install it now but what do I need to make emacs aware of it on Winodws machine? apart from adding it to path variables – doctorate Jan 12 '15 at 10:34
  • According to image-dired.el the imagemagick software is indeed a requirement since it needs its convert and mogrify executables. Therefore, install it, extend PATH if necessary and make sure you can invoke the commands in a shell, then it should work in any subsequent Emacs session. – wasamasa Jan 12 '15 at 10:38
  • yep, it worked well. Feel free to answer this post for the benefit of future users as well. – doctorate Jan 12 '15 at 10:45
  • Good, did that. – wasamasa Jan 12 '15 at 10:55
4

While most issues with images in Emacs on Microsoft Windows are caused by missing shared libraries, this one is the fault of missing executables. image-dired requires the image-magick software which provides (among others) the convert and mogrify executables. Installing it and modifying PATH to allow you to launch these in a terminal should do the trick, any subsequent Emacs session will then be able to display thumbnails in dired for you.

  • I noticed also by installation of imagemagick it offers a default option to add binary folder of executables to your path so that you don't need to add it manually by yoruself. – doctorate Jan 12 '15 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.