0

In LaTeX mode, when I type \" (to produce a Umlaut like ö, ä or ü in the resulting PDF) emacs replaces it by ''\` (two single quotation marks, a backslash, and a backtick) which does not work for typesetting Umlaute. There is a related question here. However I want to turn off this replacing under all circumstances, so that pressing " always inserts a literal " for all languages and not two single ' or anything else.

7
  • It does not happen here: I can say Here is some "quoted material" and the quotes will be replaced by double backticks on the left and double ticks (single quotes) on the right, but if I say Here is an \"umlauted letter, it is left as is. Processing it through pdflatex shows the expected. Do you have some yasnippet or some abbrev-like mechanism operating? You might want to try with emacs -q -l minimal.el where minimal.el just loads AucTeX without the rest of your configuration. If that works as expected, bisect your init file to find the culprit.
    – NickD
    Aug 5 at 15:03
  • On a completely different level, you might want to investigate using a Unicode-capable version of LaTeX (XeLaTeX or LuaLaTex) and avoid the problem.
    – NickD
    Aug 5 at 15:06
  • Can the accepted answer of emacs.stackexchange.com/questions/3546/… solve your problem?
    – Name
    Aug 5 at 15:37
  • @NickD - You can process German umlaut also with pdflatex, try for example \documentclass{article} \usepackage{lmodern} \usepackage[T1]{fontenc} \begin{document} foo föö \end{document}. Just make sure you save the .tex file in UTF-8. No need for XeLaTeX or LuaLaTeX. Aug 5 at 15:51
  • @ArashEsbati I know, but there are many limitations. If you use Unicode text (as most of us do nowadays?), you owe it to yourself to try one of the others.
    – NickD
    Aug 5 at 15:59

1 Answer 1

0

You can try setting the following variables, which are defined in tex.el.

(setq TeX-open-quote "\""
      TeX-close-quote "\"")

This allows me to enter " literally with LaTeX-mode.

2
  • this did not work for me. I still have the same issue.
    – M0M0
    Aug 5 at 14:41
  • 1
    Are you using some autopairing packages like smartparens? You can try disabling them if yes. You can also check what the " key is bound to in LaTeX-mode. That is how I identified the variables to customize. Aug 5 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.