0

Inside of eshell I get the error

LSOpenURLsWithRole() failed with error - 10810 for the file ...

if I try to use the open command on OS X. What's going on here and is there a workaround?

Edit: The error code was 10810 (not 100810). I also get the same error in emacs in shell, term, and ansi-term. open does work for me in iTerm2 and terminal. I've tried this on pdf and png files.

  • 1
    I can run open on a PDF file from eshell, and it opens in Preview. What kind of file are you trying it on? – legoscia Jan 12 '15 at 16:36
  • Does the same command work without error in Terminal.app? Does it work inside M-x shell? Are you sure you haven't made a typo in the error code? Googling suggests 10810 is more likely than 100810. – deprecated Jan 12 '15 at 18:18
  • @legoscia I tried a PDF, same error. @deprecated It does work in Terminal.app but not in M-x shell. I fixed the error number, thanks. – Praxeolitic Jan 12 '15 at 18:55
  • 1
    The 10810 is a generic error. More specifics are written to /var/log/system.log, which may explain the true source of open errors. It could be as simple as filename error or as complex as restarting finder or window server. – Emacs User Jun 13 '15 at 23:02
  • 1
    It works out of the box for me using the most recent public release of Emacs -- i.e., 24.5 -- on Snow Leopard 10.6.8. – lawlist Jun 14 '15 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.