1

I have a strange problem that I've observed using GNU Emacs 28.1 on gnome + arch linux. I have a commands bound in my .emacs to C-, and C-., which I wrote a long time ago to jog up and down the buffer.

Recently (at least a year) I noticed that C-, still works but C-. doesn't. Instead, when I press C-. I get a weird contextual cursor that I've never seen before. It looks like a tooltip and has the letter 'e'. see screenshot:

enter image description here

If I type, the typing gets added to the bubble:

enter image description here

If I press escape it goes away. I don't know what this is but I've only seen it in emacs. When I press C-h k to describe-key and then enter C-., the same phenomenon occurs.

It seems like the key is getting captured before emacs interprets it- but there is definitely no keybinding at the desktop level- I've checked. Nothing happens in any other app.

Any idea what is going on?

2
  • 2
    This is a duplicate question (I've seen it asked and answered at least a couple of times before), but I can't find it right now. It's your OS or window manager claiming that keystroke before it gets to Emacs, so you need to find and disable that outside of Emacs in order for Emacs to receive that key.
    – phils
    Aug 13 at 5:47
  • Indeed it is.. it is apparently an undisclosed utility for picking emoji.. gsettings get org.freedesktop.ibus.panel.emoji hotkey. I have no idea where this came from but I can turn it off! Aug 13 at 6:04

2 Answers 2

2

It’s Gnome’s default IME, ibus. As usual, ArchWiki has good documentation: https://wiki.archlinux.org/title/IBus

2
  • Thanks! It doesn't seem to do anything in other apps (e.g. in this edit window, Ctrl-. does nothing, although I can copy and paste an emoji entered from emacs: 👋). Any idea where else it could be used? Aug 13 at 6:20
  • 1
    That’s a GNOME question, and all we have are Emacs answers.
    – db48x
    Aug 13 at 6:39
2

OK, it is indeed a keyboard shortcut that is being captured by the system as a "pre-edit area" for entering emoji. Entering C-. <space> reveals:

enter image description here

I don't know when/by what it was introduced, but it can be viewed and edited with gsettings:

$ gsettings get org.freedesktop.ibus.panel.emoji hotkey 
['<Control>period']
$ gsettings set org.freedesktop.ibus.panel.emoji hotkey []

I found it here: https://askubuntu.com/questions/1372781/new-ctrl-period-key-sequence-default-in-21-10

See also: https://superuser.com/questions/1687342/what-is-my-x11-doing-with-ctrl-period-and-how-can-i-disable-it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.