6

I noticed something strange when calling C-h v (describe-variable) on exec-path today:

exec-path is a variable defined in `C source code'.

Its value is

("/usr/bin" ...)

Original value was

("/home/juergen/.opam/4.02.0/bin" "/home/juergen/.cabal/bin" "/usr/local/sbin" "/usr/local/bin" "/usr/bin" "/opt/google-appengine-java/bin" "/usr/lib/jvm/default/bin" "/usr/bin/site_perl" "/usr/bin/vendor_perl" "/usr/bin/core_perl" "/home/juergen/Android/ndk/" "/home/juergen/.gem/ruby/2.0.0/bin/" "/home/juergen/bin/" "/home/juergen/bin/gnome-terminal-colors-solarized" "/home/juergen/tmp/emacs/trunk/src/emacs-24.4/lib-src" "/usr/lib/emacs/24.4/x86_64-unknown-linux-gnu")

The thing is, there is no user called juergen on my system.

Q: Is this the exec-path of the user who originally compiled the Emacs binary I am using? If so, why does its value get carried over into a binary that is distributed to end users? Shouldn't exec-path have a more generic default value (i.e., a value that doesn't include any /home/juergen entries)?

  • I'm still on 24.3, and there's no juergen on my exec path. Do you get the same path with emacs -Q? – Dan Jan 13 '15 at 11:34
  • 4
    Shot in the dark, but you're not, by chance, running Arch, are you? Its package for 24.4.1 is maintained by a Juergen. – Dan Jan 13 '15 at 11:40
  • 1
    @Dan If that's a shot in the dark, you must be wearing night vision goggles. I think you solved it. My Emacs from the Arch repo originally had Juergen's exec-path as well. – nanny Jan 13 '15 at 14:47
  • @Dan Yes, I Emacs reports the same default value for exec-path in vanilla Emacs. And yes, I'm running Arch - how did you know? ;) – itsjeyd Jan 13 '15 at 21:03
  • Wow, well, google for the win. I did a google search for "emacs juergen" just to see what turned up -- this thread is the top hit, followed by the two items I'd linked earlier. I'm rather startled that it worked. ;) – Dan Jan 13 '15 at 23:01
6

It does sound like this was caused by the user who originally built the binary for you. If they didn't do so in some sort of stripped down environment then this would happen.

You might want to report it to the maintainers of your binary package so that they can fix the problem with their build process.

If you provide information about what platform you are running Emacs on it would be helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.