I want to long commit messages to be truncated rather than wrapped around in magit buffers only because I can simply open a commit to see the full message.

I tried

(add-hook 'magit-mode-hook (lambda () (setq truncate-lines t)))

but that didn't have any effect; truncate-lines is still nil when I eval it in a magit buffer.

I'm using Spacemacs if that makes a difference.

1 Answer 1


truncate-lines is enabled by default in magit-mode buffers, so your hook function isn't actually changing anything.

You need to find what else it is that you'd previously done in your config to prevent that setting from remaining in effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.