1

I'm trying to customize my agenda. My tasks have the following states: NEXT, WAITING, TODO and DONE. I want to customize my agenda view so that no header is shown. So far, I have:

(setq org-agenda-custom-commands
      '(("b" "Test"
     ;; commands
     ((agenda "" ((org-agenda-span 7)
              (org-deadline-warning-days 30)))
      (todo "NEXT" ((org-agenda-overriding-header "")))
      (todo "WAITING" ((org-agenda-overriding-header "")))
      (todo "TODO" ((org-agenda-overriding-header "")))))))

but in this way, an empty line is shown before each section. Is there any way to get rid of the header at all?

1

The space between agenda blocks is controlled by org-agenda-block-seperator.

The separator between blocks in the agenda. If this is a string, it will be used as the separator, with a newline added. If it is a character, it will be repeated to fill the window width. If nil the separator is disabled. In ‘org-agenda-custom-commands’ this addresses the separator between the current and the previous block.

Setting it to nil removes the separator entirely, leaving only org-agenda-overriding-header between the blocks, which you can also leave as nil instead of an empty string.

  • Tried it but the empty line is still there. – petrux Aug 27 '15 at 9:18
  • Does setting org-agenda-compact-blocks to t help? – erikstokes Aug 27 '15 at 12:22
  • Unfortunately, no. I added the (setq org-agenda-compact-blocks to t) in the org config file... shall I add it in the custom command? – petrux Aug 28 '15 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.