0
$ ecat app/models/insurance_policy_revenue.rb
../dotfiles/.emacs.d/my_lisp/face-explorer/face-explorer.el: Warning: Use keywords rather than deprecated positional arguments to `define-minor-mode'
../dotfiles/.emacs.d/my_lisp/face-explorer/face-explorer.el: Warning: Use keywords rather than deprecated positional arguments to `define-minor-mode'
...

I'm using ecat

1 Answer 1

0
  1. If you want to remove the need for those warnings then change the definitions that use define-minor-mode so that they use those keywords instead of providing the same info as (positional) arguments.

  2. If you just want to prevent the warnings from being displayed/printed then you can fiddle with the available warning options described in node Warning Options of the Elisp manual.

  3. Otherwise, just ignore those "warnings". There's nothing really to warn about.

(This has nothing to do with shell or shell command ecat. The warning message tells you that it's about some code in file face-explorer.el.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.