3

I have been using Emacs for a while. As you can see in my config file (whole file), there is a snippet to provide a Doom mode line:

(use-package doom-modeline
  :init (doom-modeline-mode 1)
  :custom ((doom-modeline-height 15)))

Unexpectedly, I started Emacs and now I am seeing some Chinese characters (left side):

enter image description here

This also happens in e-shell:

enter image description here

I suppose this might be some Unicode problem. Also, I must highlight that I am not Chinese, I do not speak Mandarin. So, this is completely random in my system for me and I have never seen such a thing before.

Why is this happening? How can I fix this?

3
  • 3
    This looks like a duplicate of emacs.stackexchange.com/questions/73120/…
    – phils
    Sep 2, 2022 at 1:33
  • Try running both M-x all-the-icons-install-fonts and M-x nerd-icons-install-fonts.
    – Muir
    Sep 6, 2023 at 16:19
  • Sorry, I tried your approach but I am still seeing some chinese icons in eshell, for instance. I also restarted emacs after executing your commands. Sep 8, 2023 at 1:55

1 Answer 1

2

Have you tried M-x all-the-icons-install-fonts?

1
  • Thanks. I tried that. And it did not work. I am new to macOS. I think I pressed some random keybinding, that opened a font or typography menu, and I accidentally clicked on something. Now, I do not know how to re-store the previous state. Sep 8, 2022 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.