0

I am using Emacs 23 under Mac OS X. When I open certain files I get the following error when I try to save them:

Warning: ns-convert-utf8-nfd-to-nfc unsupported under GNUstep.

insert-file-contents: Wrong type argument: char-or-string-p, nil

Sometimes the opening of new files fails with the same message. When I retry opening them, it works. I have no idea how to fix this. In general unicode works fine.

  • Start by making sure it's not your personal configuration that's causing the issue: Launch Emacs via emacs -Q and try to reproduce the behavior. If you can't, this means that the issue is related to your personal config. Report back with the results you get. – itsjeyd Jan 14 '15 at 9:28
  • The public version of Emacs is now at 24, so consider upgrading. – lawlist Feb 17 '15 at 15:51
  • (setq debug-on-error t) will give you a backtrace when the error is raised. That will give you some more info about what's going on - what function is expecting a char or string and received nil instead, etc. – Drew Jun 10 '15 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.