1

When using clippy with rustic mode, I'm unable to read any of the blue messages on my screen. I would like to change the color so I can read these messages.

unreadable font

Existing answers tell me to adjust the font settings, yet I can't seem to find the font face here:

font description

How would I go about redefining "blue2" to be a more readable shade of blue?

1
  • See this answer for a possible solution. If that does not work, try my answer to the same question. If one of these answers your question, this question can be marked as a duplicate.
    – NickD
    Oct 11, 2022 at 1:40

2 Answers 2

2

Looking into rustic-mode revealed rustic-ansi-faces, which can be used to customize the colors in which the cargo compilation output is displayed. I changed it to the following for better legibility:

(setq rustic-ansi-faces ["black"
                              "red2"
                              "green3"
                              "yellow3"
                              "cyan2"
                              "magenta3"
                              "cyan3"
                              "white"])

result

0

The owner of the face is xterm-color. I believe you are using this package xterm-color.el: An ANSI control sequence to text-property translator.

Are you running any shell commands that turns on color output? Are you looking at the error messages of a compiler, and the compiler colorizes the output, and Emacs picks up those colors? (IIRC, with rg, ag and language compilers commands turns on colour on the output)

There is dissonance between the Emacs themes, and the colors output by these commands.

You have the following options

  • Look at the command line option of your linter, compiler, or search commands, and disable the color option.

  • Or disable xterm-colors to see if there is a change in the situation.

1
  • Thanks, this prompted me to look into the rustic-mode package which uses xterm-color internally. There I could configure the color - see my answer.
    – DeinFreund
    Oct 11, 2022 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.