0

Rustic (I think) keeps giving me what appears to be not-yet-filled-in completion.

When I type e.g. env::va I get suggestions that include var(...), as expected, but when I hit return I end up with env::var(${1:key})$0 in my text file, with point at the end of it. I'm assuming this is supposed to be a template that I tab through, filling in the values, but it's just left there as a literal string.

Not sure what the problem could be or even where to start digging into this besides taking my whole emacs config back to scratch and seeing if anything else is interfering with this - any suggestions would be appreciated!

1 Answer 1

0

Turn off yasnippet with M-x yas-minor-mode

If you are using company, remove yasnippet from the company-backends.

1
  • That's done the trick - thanks very much! Oct 18, 2022 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.