3

I'm using gnus and trying to send email through it. This works for my gmail account (which receives outgoing emails on smpt port 587 using tls). My university uses smpt on port 465 and no tls, but ssl. Receiving email via IMAP port 993 works perfectly, but I have found no setup which allows email to be sent via port 465 ssl.

Short of looking at the source and debugging this myself, which would likely involve looking at how gnus is doing authentication and learning about the authentication methods and the smpt protocol, I don't think I will get any further.

I notice that everywhere that this question exists, it never gets answered.

http://comments.gmane.org/gmane.emacs.gnus.general/83505

https://groups.google.com/forum/#!topic/gnu.emacs.gnus/1_8s2pCWy4I

https://groups.google.com/d/topic/gnu.emacs.gnus/ikGoITEYIf4

http://www.linuxquestions.org/questions/linux-software-2/sending-email-with-gnu-emacs-process-smtp-not-running-error-4175415954/

And this has apparently been going on since 2010, so I thought it'd post it here.

What is a working setup for sending email from gnus via port 465 ssl?

migrated from emacs.meta.stackexchange.com Jan 17 '15 at 0:48

This question came from our discussion, support, and feature requests site for those using, extending or developing Emacs.

  • Would something like this help?: (setq tls-program '("openssl s_client -connect %h:%p -no_ssl2 -ign_eof")) And, then just the regular port setting stuff with 465, etc. – lawlist Jan 17 '15 at 0:54
  • unfortunately, it does not seem to help. have you been able to successfully send email through port 465? – erjoalgo Jan 17 '15 at 1:12
  • I'm sorry I wasn't able to help. No, I've not had the opportunity to use port 465 with gnu email. I had thought perhaps the issue was just a matter telling tls to use openssl (so that you can use tls quote-unquote, but really be using ssl), but I was evidently mistaken. I hope other forum participants can be of better assistance. – lawlist Jan 17 '15 at 4:38
2

I had the same problem. Could send mail from home but not at university. I struggle with it for days. I was already using but I was using the port 587. Then changing to port 465 did the job.

So may be you only have to add

(setq smtpmail-stream-type  'ssl)  

Make sure you don't have any port number specified in your .authinfo file, it might override the one you specify in .gnus

Here is an extract from my .gnus.

(setq send-mail-function    'smtpmail-send-it
  smtpmail-smtp-server  "smtp.gmail.com"
  smtpmail-stream-type  'ssl
  smtpmail-smtp-service 465
  smtpmail-debug-info t
  smtpmail-debug-verb t)

May the force be with you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.