7

I'm using Kubuntu 22.04 and I tried to configure my doom-emacs Installation. Then I got these weird error-messages and couldn't figure out how to fix them. So I uninstalled doom and emacs completely and normal emacs seems to work fine but when I try to run doom emacs I get them again: This is the output of doom doctor:

doom doctor The doctor will see you now...

Checking your Emacs version...
Checking for Doom's prerequisites...
Checking for Emacs config conflicts...
Checking for great Emacs features...
! Emacs was not built with native compilation support
Users will see a substantial performance gain by building Emacs with native compilation support, availible in emacs 28+.You must install a prebuilt Emacs binary with this included, or compile Emacs with the --with-native-compilation option. Checking for private config conflicts...
Checking for stale elc files...
x There was an unexpected runtime error
Message: File is missing Details: ("Opening directory" "No such file or directory" "/home/user/.emacs.d/.local/straight/build-28.1")
Backtrace: (file-name-all-completions "" "/home/user/.emacs.d/.local/straight/build-28.1")
(directory-files-recursively "/home/user/.emacs.d/.local/straight/build-28.1" "\.elc$")
(let ((--dolist-tail-- (directory-files-recursively dir "\.elc$"))) (while --dolist-tail-- (let ((file (car --dolist-tail--))) (if (file-newer-than-file-p (conc...
(elc-check-dir "/home/user/.emacs.d/.local/straight/build-28.1") (let nil (doom-print (doom-print--format "The doctor will see you now...\n")) (doom-print (doom-print--format (doom-print--class 'start "Checking your Emacs vers... ((closure (t) (cli alist) (let nil (doom-print (doom-print--format "The doctor will see you now...\n")) (doom-print (doom-print--format (doom-print--class 'start... (funcall (closure (t) (cli alist) (let nil (doom-print (doom-print--format "The doctor will see you now...\n")) (doom-print (doom-print--format (doom-print--clas... (doom-cli-execute #s(doom-cli ("doom" "doctor") nil (("SUMMARY" . "Diagnoses common issues on your system.") ("MAIN" . "The Doom doctor is essentially one big, s... (let ((cli x16) (bindings x17)) (doom-cli-execute cli bindings)) (let* ((x16 (car-safe x15)) (x17 (cdr-safe x15))) (let ((cli x16) (bindings x17)) (doom-cli-execute cli bindings))) (progn (ignore (consp x15)) (let* ((x16 (car-safe x15)) (x17 (cdr-safe x15))) (let ((cli x16) (bindings x17)) (doom-cli-execute cli bindings)))) (let ((x15 (car --dolist-tail--))) (progn (ignore (consp x15)) (let* ((x16 (car-safe x15)) (x17 (cdr-safe x15))) (let ((cli x16) (bindings x17)) (doom-cli-execut...
Setting current directory: No such file or directory, /home/user/.emacs.d/.local/straight/build-28.1

And this is the output of doom sync:

x There was an unexpected runtime error
Message: Wrong type argument
Details: (stringp afternoon-theme)
Backtrace:
(intern afternoon-theme)
((closure ((package . gnu-elpa-mirror) use-package-pre-ensure-function use-package-keywords use-package-ensure-function use-package-defaults package-selected-pac...
(cl--position gnu-elpa-mirror ((afternoon-theme :url "https://github.com/osener/emacs-afternoon-theme" :ignored-files (".png")) (alect-themes :url "https://gith...
(cl-position gnu-elpa-mirror ((afternoon-theme :url "https://github.com/osener/emacs-afternoon-theme" :ignored-files ("
.png")) (alect-themes :url "https://githu...
(apply cl-position gnu-elpa-mirror ((afternoon-theme :url "https://github.com/osener/emacs-afternoon-theme" :ignored-files (".png")) (alect-themes :url "https:/...
(cl-find gnu-elpa-mirror ((afternoon-theme :url "https://github.com/osener/emacs-afternoon-theme" :ignored-files ("
.png")) (alect-themes :url "https://github.co...
(straight-recipes-nongnu-elpa--translate (cl-find package (straight-recipes-nongnu-elpa--recipes) :key #'(lambda (it) (intern (car it)))))
(straight-recipes-nongnu-elpa-retrieve gnu-elpa-mirror)
(apply straight-recipes-nongnu-elpa-retrieve gnu-elpa-mirror)
(let ((default-directory (if local-repo (straight--repos-dir local-repo) default-directory)) (func (intern (format "straight-recipes-%S-%S" name method)))) (appl...
(let* ((--cl-rest-- recipe) (local-repo (car (cdr (plist-member --cl-rest-- ':local-repo))))) (let ((default-directory (if local-repo (straight--repos-dir local-...
(let ((recipe (straight--convert-recipe name cause))) (let* ((--cl-rest-- recipe) (local-repo (car (cdr (plist-member --cl-rest-- ':local-repo))))) (let ((defaul...
! Wrote extended backtrace to ~/.emacs.d/.local/logs/cli.doom.221126091321.15545.error

I tried to find the file where (stringp afternoon-theme) is supposed to be but I didnt't find it in the config files config.el,init.el or packages.el

This is some content of the error file .emacs.d/.local/logs/cli.doom.221126134605.37527.error:

;; -- lisp-interaction -- ;; vim: set ft=lisp: ;; command=("emacs" "--load" "/home/jannis/.emacs.d/bin/doom" "--" "sync" "-up") ;; date="2022-11-26 13-46-05"
;;;; ENVIRONMENT GNU Emacs v28.1 nil Doom core v3.0.0-pre grafted, HEAD -> master, origin/master, origin/HEAD 9d4d5b7 2022-10-31 16:18:16 +0100 Doom modules v22.10.0-pre grafted, HEAD -> master, origin/master, origin/HEAD 9d4d5b7 2022-10-31 16:18:16 +0100
;;;; 0 ((intern afternoon-theme) ((debugger-may-continue . t) (inhibit-redisplay) (inhibit-debugger . t) (inhibit-changing-match-data)))
;;;; 1 (((closure ((package . gnu-elpa-mirror) use-package-pre-ensure-function use-package-keywords use-package-ensure-function use-package-defaults package-selected-packages package--builtins t) (it) (intern (car it))) (afternoon-theme :url "https://github.com/osener/emacs-afternoon-theme" :ignored-files (".png"))) ((package . gnu-elpa-mirror) (it afternoon-theme :url "https://github.com/osener/emacs-afternoon-theme" :ignored-files (".png"))))

I can't find any of these lines in any other file

3
  • 1
    (intern afternoon-theme) is the problem, because afternoon-theme didn't have a string value (as intern requires a string argument). I suggest just searching for afternoon-theme with M-x rgrep.
    – phils
    Nov 26, 2022 at 12:48
  • I found it only in an error log of emacs ~/.emacs.d/.local/logs/cli.doom.221126133700.36714.error
    – Tom Riddle
    Nov 26, 2022 at 13:16
  • Ok. I know very little about Doom or Straight, and I don't know what's going on there, but hopefully someone else has some insight.
    – phils
    Nov 26, 2022 at 13:23

1 Answer 1

10

There was an issue with the latest straight.el commit.

https://github.com/doomemacs/doomemacs/issues/6960

One way to fix it, is to update straight repo and getting latest version of straight , that fixed it for me. it is fixed in straight here radian-software/straight.el@3eca39d

@unuunc Thank you.

Add some details:

cd ~/.emacs.d/.local/straight/repos/straight.el git pull origin develop

You can upgrade if you pin straight first in packages.el

(package! straight :pin "3eca39d")

If you don't care about upgrading for now you can skip the unpin in packages.el and just doom sync

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.