1

I found this which would seemingly indicate that you just run

(setq org-html-table-caption-above nil)

if you want the caption to appear below the table. But it doesn't. How can I make the caption appear below the table

#+CAPTION: A table caption  
#+ATTR_HTML: :border 2 :rules all :frame border
|---+---+---+---+---+---|
| 1 | 2 | 3 | 4 | 5 | 6 |
|---+---+---+---+---+---|
| T | T | F | T | F | T |
|   |   |   |   |   |   |
|   |   |   |   |   |   |
|   |   |   |   |   |   |
|---+---+---+---+---+---|
5
  • Works for me. Check the value of the variable with C-h v org-html-table-caption-above to make sure that your setting has "taken".
    – NickD
    Dec 2, 2022 at 18:25
  • Also if you are checking the page in your browser, don't forget to refresh it !-)
    – NickD
    Dec 2, 2022 at 18:58
  • Yes, and for me when I do a emacs -Q it's fine. I looked through my init-world and couldn't find anything that should countermand the setq. So I just changed my custom CSS to include caption.t-bottom {...caption-side: bottom}. I'm on 9.6 while the default clean is 9.5.5(?).
    – 147pm
    Dec 2, 2022 at 20:36
  • You are papering over the problem this way. The best thing to do is bisect your inif tile and find out exactly what is causing the problem.
    – NickD
    Dec 2, 2022 at 20:49
  • 1
    Will do. And report.
    – 147pm
    Dec 3, 2022 at 19:41

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.