3

Suddenly, I'm getting the error "No such file or directory" "helm-config" when I start Emacs. Here's what I have in my config.org which is called by init.el

(use-package helm
    :ensure t
    :bind
    ("C-x C-f" . 'helm-find-files)
    ("C-x C-b" . 'helm-buffers-list)
    ("M-x" . 'helm-M-x)
    :config
    (defun daedreth/helm-hide-minibuffer ()
      (when (with-helm-buffer helm-echo-input-in-header-line)
        (let ((ov (make-overlay (point-min) (point-max) nil nil t)))
          (overlay-put ov 'window (selected-window))
          (overlay-put ov 'face
                       (let ((bg-color (face-background 'default nil)))
                         `(:background ,bg-color :foreground ,bg-color)))
          (setq-local cursor-type nil))))
    (add-hook 'helm-minibuffer-set-up-hook 'daedreth/helm-hide-minibuffer)
    (setq helm-autoresize-max-height 0
          helm-autoresize-min-height 40
          helm-M-x-fuzzy-match t
          helm-buffers-fuzzy-matching t
          helm-recentf-fuzzy-match t
          helm-semantic-fuzzy-match t
          helm-imenu-fuzzy-match t
          helm-split-window-in-side-p nil
          helm-move-to-line-cycle-in-source nil
          helm-ff-search-library-in-sexp t
          helm-scroll-amount 8 
          helm-echo-input-in-header-line t)
    :init
    (helm-mode 1))


  (require 'helm-config)
  (helm-autoresize-mode 1)
  (define-key helm-find-files-map (kbd "C-b") 'helm-find-files-up-one-level)
  (define-key helm-find-files-map (kbd "C-f") 'helm-execute-persistent-action)

This popped up upon recent restart -- and I can't think of anything I've changed. So when I comment out the (require 'helm-config) things seem to go back to normal. Any ideas what this is about?

2
  • Check your load-path and make sure that the directory where helm-config.el lives is accessible.
    – NickD
    Dec 14, 2022 at 17:41
  • 4
    Maybe the mystery is solved: Checking github.com/emacs-helm/helm I see a commit comment "Delete helm-config file no more useful" attached to emac-helm.sh. And no, there is no more helm-config.el in my elpa/20221212.628 but there was in older backup versions I have. So just comment it out. Life is good.
    – 147pm
    Dec 14, 2022 at 19:32

1 Answer 1

2

I ran into this, yesterday. As suggested in the comments, removing (require 'helm-config) resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.