1

[Crossposting from gnu.emacs.help after getting no response there.]

With Emacs 27.1, in the terminal the standard colour scheme, the pop-ups of the menu I get via F10 have a blue background and with the foreground for menu items being either white(-ish) or browny-orange. The highlighting background colour for selection is red, which for makes the browny-orange illegible.

My question is: How do I change the colour of the pop-ups?

The following changes the menu-bar itself, but not the pop-ups:

    (set-face-attribute 'menu nil
                        :inverse-video nil
                        :background "blue"
                        :foreground "white"
                        :bold t)
3
  • It goes through menu-bar-open->popup-menu->x-popup-menu (C code) -> x_popup_menu_1 but then I lost track: I don't know how the colors are assigned. OTOH, things are perfectly legible for me: wheat against either a blue background or a red background. Not sure why you get brown-orange.
    – NickD
    Dec 21, 2022 at 13:09
  • Following @dalanicolai's answer, when I use emacs -nw -q, customize claims that the foreground for tty-menu-enabled is yellow, but it looks pretty grubby to me.
    – loris
    Dec 21, 2022 at 15:25
  • Only one question per post, please. Please edit to remove all but one of your questions here. Post the others separately. Thx.
    – Drew
    Dec 21, 2022 at 17:46

2 Answers 2

2

M-x list-faces-display can be used to list all faces. Then, by quickly scrolling through all faces and looking for faces that resemble the 'menu-bar pop-up face', it can be quickly found that the names of the faces used for the menu-bar pop-up start with tty-menu-.... Now, simply use M-x customize-face tty-menu-enabled/disabled/selected to configure the popup faces.

0

I have subsequently realised that the settings of my Gnome terminal were influencing the colours of the Emacs menu. For the setting Preferences / Colours / Palette / Built-in schemes I had Solarized, which lead to the rather hard to read grubby yellow on lightish blue. Changing this setting to Gnome or Xterm results in a more legible scheme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.