1

The line below is in my init file:

(require 'semantic/db-javap)

it is causing the following error message:

Debugger entered--Lisp error: (file-error "Cannot open load file" "semantic/db-javap")
  require(semantic/db-javap)
  eval((require (quote semantic/db-javap)) nil)
  eval-last-sexp-1(nil)
  eval-last-sexp(nil)
  call-interactively(eval-last-sexp nil nil)

There are other semantic lines in my init file too, but this is the only one throwing an error.

It appears that CEDET comes installed by default, so why is this the only file missing? And what can I do to fix it?

Other relevant lines:

(global-ede-mode 1) ; Enable the Project management system
(require 'semantic/sb)
(require 'semantic/bovine/gcc)
(require 'semantic/db-javap)
(require 'semantic/ia)
(add-to-list 'semantic-default-submodes 
         '(global-semantic-idle-local-symbol-highlight-mode 
          global-semantic-idle-scheduler-mode
          global-semantic-idle-completions-mode))
(semantic-mode 1)

Emacs version 24.3.1

2

so why is this the only file missing?

Because the CEDET guys feel that the Java support hasn't received enough attention (development, testing, adoption) to be ready for inclusion into Emacs.

To use it, you'll have to install the upstream CEDET, or maybe Alex Ott's branch (see this question and answer).

And what can I do to fix it?

Show some activity on the CEDET mailing lists, report which version works better for you and any bugs you encounter.

Hopefully, that would inspire the guys to iron out any outstanding issues, and to have more confidence in that code, to include in Emacs.

  • Yes, that's probably not the answer you were looking for. :) – Dmitry Jan 19 '15 at 0:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.