0

When I refile (C-c C-w) a TODO entry under another heading, I get an icon in the left margin. The icon looks like a red dot, similar to the icon used for breakpoints in IDEs.

Here's a before and after image (note the red dot in the 2nd image):

enter image description here

enter image description here

The docs for refiling don't mention any symbol or visual cue that appears after refiling.

It would be great if there was a variable I could set so the icon doesn't appear at all.

My system:

  • OS: Windows
  • Emacs: GNU Emacs 28.2 (build 2, x86_64-w64-mingw32)
  • Org mode: 9.5.5
3
  • 1
    Does this answer your question? meaning of a red dot on border of window
    – NickD
    Commented Jan 3, 2023 at 20:26
  • 1
    Hi @NickD I took a look at your link, but setting (setq org-capture-bookmark nil) (manual) in my Emacs conf file doesn't work. I still get the red dot.
    – edo
    Commented Jan 5, 2023 at 18:06
  • That's because the capture bookmark and the refile bookmark are different. However, there is no org-refile-bookmark variable to set: not sure why that is. I'll provide an answer that seems to work for me.
    – NickD
    Commented Jan 5, 2023 at 18:48

2 Answers 2

1

As mentioned in the related answer, the red dot in the fringe signifies a bookmark. The OP tried to suppress it by setting org-capture-bookmark to nil, but that does not work: org-refile uses a bookmark, but it is a different bookmark.

By extension, one could imagine that there should be a variable org-refile-bookmark that could be set to nil to suppress the org-refile bookmark, but there isn't one: probably an error of omission.

However, the bookmarks that Org mode uses are stored in a different variable org-bookmark-names-plist. This is a plist as its name implies with the default value (:last-capture "org-capture-last-stored" :last-refile "org-refile-last-stored" :last-capture-marker "org-capture-last-stored-marker").

This variable can be customized (do C-h v org-bookmark-names-plist and click on the Customize link) to eliminate whichever bookmark(s) one does not care about by clicking on the DEL button(s). If I delete the :last-refile entry (and restart emacs), then the org-refile bookmark is not set for me. Restarting seems necessary only in the sense that the red dot in the fringe does not seem to go away otherwise, even though the bookmark is not set (although there might be a simpler way to reset the fringe).

If you don't want any bookmarks, you can delete the other entries in the customization buffer as well, then hit Apply and Save and restart Emacs. You will never see these bookmarks again.

4
  • I did some additional testing, and after refiling I saved the file, exited Emacs, started it again, reopened the same file and the red dot is gone. So I guess restarting Emacs is the simplest fix for my problem. Still, it would be great if there was a way to prevent the creation of the red dot, i.e., bookmark.
    – edo
    Commented Jan 6, 2023 at 15:37
  • I misspelled the name of the variable (I fixed it now): it should be org-bookmark-name-plist. If you customize that as described, the bookmark will never be created. Sorry for the confusion.
    – NickD
    Commented Jan 6, 2023 at 15:48
  • Thanks, that worked! With this line in my Emacs conf file, the refiling bookmarks are not created: (setq org-bookmark-names-plist '(:last-capture "org-capture-last-stored" :last-capture-marker "org-capture-last-stored-marker")).
    – edo
    Commented Jan 6, 2023 at 17:29
  • Typo in my previous comment: the name should be org-bookmark-names-plist.
    – NickD
    Commented Feb 6, 2023 at 5:59
2

I also wanted to get rid of that dot, not just for the bookmarks org set's but for all bookmarks. It's the setting bookmark-set-fringe-mark, you can add to your init file:

(setq bookmark-set-fringe-mark nil)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.