0

When I C-x to show the list of commands, the window of commands is chopped like below

enter image description here

how can I make it show the full?

4
  • 1
    C-x all by itself, in a default installation of Emacs without any user configuration, does not bring up any window with possible commands. C-x is a prefix that will cause Emacs to wait for the next user input; i.e., a combination of keys that begins with the prefix ....
    – lawlist
    Commented Jan 9, 2023 at 22:39
  • What @lawlist said. Please provide the steps you use to reproduce what you see, starting with emacs -Q (no init file). And please specify your Emacs version (release).
    – Drew
    Commented Jan 9, 2023 at 22:57
  • 1
    Shown is doom emacs. Emacs version is 28.2 Commented Jan 9, 2023 at 23:14
  • I get this behaviour when I increase the font in doom emacs. So far have not been able to find a fix. Frame Max Height setting doesn't seem to work. Commented Mar 1, 2023 at 18:57

2 Answers 2

1

You’re looking at which-key-mode, which is not technically part of Doom Emacs, just something it installs and turns on for you. Like any good Emacs package, which-key provides a number of customizable settings. To see them, run M-x customize-group and enter which-key when prompted.

In particular, look for the “Which Key Frame Max Height” setting, which defaults to 20. The mode does not always use that many lines; after a quick skim of the code I see that it has some complicated adaptive behavior. I think it tries to divide the available keys up into pages of roughly equal size, though I’m not very sure. You may need to read the source code yourself, or examine the settings more carefully, or contact the author directly.

0

C-h to see the help-row at the bottom. It should n for next, p for previous.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.