0

The key binding problem happens only when using Emacs in WSL terminal.

For example:

  • I can not add priorities on headings with shift+arrow key
  • I can not collapse all headings with shift+tab
  • I have a binding for Ctrl+backspace, it does not work
  • Alt+enter should add new heading when in org mode - it doesn't
  • Also when trying to schedule a date - I can not choose it with shift+arrow keys

It is only a few things I managed to spot today. I believe if I used terminal mode longer - I would find more hiccups like this.

Not sure what is causing it..

1 Answer 1

1

You’re using Emacs inside of a terminal, and terminals have a much more limited set of keystrokes that they can communicate. This is because historically terminals simply had fewer keys on their keyboards, and because not all combinations of keys were thought to be useful.

Some terminal emulators, starting with XTerm, have added new escape sequences that are capable of communicating the full range of key combinations possible on modern keyboards. Emacs will automatically recognize these escape sequences, so if your terminal emulator supports them then you have a solution. If it doesn’t perhaps you can use XTerm instead.

2
  • Thank you, I learned something new. But I downloaded Xterm on my Ubuntu machine, launched emacs in it with emacs -nw, the same bindings still dont work.
    – Arvydas
    Jan 14, 2023 at 5:59
  • Note the link to the XTerm documentation. You have to set a configuration option to a non–default value before it will send these non–standard escape sequences.
    – db48x
    Feb 7 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.