0

I am trying to prevent emacs-jupyter package from native compilation. There is a known bug that breaks the package when native compiled. [1] I can manually delete the eln files in eln-cache dir and package starts working. I tried the suggested solutions. Apperently this variable no longer exists,

(setq comp-deferred-compilation-deny-list (list "jupyter"))

how ever this variable does exists,

(add-to-list 'native-comp-deferred-compilation-deny-list ".*emacs-jupyter.*")

however I tried various regex expressions to match emacs jupyter but emacs (28.2) seems to be ignoring this variable. Is there a special format to this regex?

[1] https://github.com/nnicandro/emacs-jupyter/issues/297

1
  • 1
    I presume that the name of the variable was misspelled in the first case (they just neglected to add the native- part). Why don't you try the regexp from it, i.e. just "jupyter", and see if that works? That's a flying guess mind you.
    – NickD
    Commented Jan 28, 2023 at 2:40

1 Answer 1

2

this is how I use the variable to block compilation of a package (this is on Windows)

(setq native-comp-deferred-compilation-deny-list '("worf"))

It took a lot of experimentation to get this right.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.