0

I am using Emacs 26.4 from ubuntu repository on ubuntu 20.04.

I have swtiched from ESS by the ubuntu repository to the MELPA ESS, in order to have ESS working with R-4 (see this: ESS start process does not include new R version).

I have two inconveniences:

  1. how to have the smart underscore? I have tried a package but I did not manage to make it work

  2. I have install auto-complete, but still have the issue: ess-command: Symbol’s function definition is void: ess-local-process-name

2
  • Did you get this figured out? I'm running getting a similar error (ess-r--init-error-handler: Wrong type argument: listp, "Caused by error: Symbol’s function definition is void: ess-local-process-name" when I try to start an R process on a 23.04 machine with R and emacs 27.1. I can only fix it by reverting to an older version of ess. See: (github.com/emacs-ess/ESS/issues/1140) for more details Commented Oct 13, 2023 at 17:13
  • Unfortunately I do not remember anymore how I did. I see that now I have Emacs 26.3 and ESS 18.10.2 from the standard Ubuntu repository and the smart underscore works fine.
    – Alessandro
    Commented Nov 16, 2023 at 15:07

1 Answer 1

1

I think that ESS is no longer providing support for auto-complete package. The default is Company try installing it and ESS should recognize it by default. Or you might need to require it and activate it, I have it globally.

Here is my config with comments in case you need it:

(use-package company
    :config
    ;; Turn on company-mode globally:
    (add-hook 'after-init-hook 'global-company-mode)
  ;; More customization options for company:
  (setq company-selection-wrap-around t
    ;; Align annotations to the right tooltip border:
    company-tooltip-align-annotations t
    ;; Idle delay in seconds until completion starts automatically:
    company-idle-delay 0.45
    ;; Completion will start after typing two letters:
    company-minimum-prefix-length 3
    ;; Maximum number of candidates in the tooltip:
    company-tooltip-limit 10))

Alternatively you can try using Corfu.

Also, if you are using the packages from Melap you might want to update to Emacs 29, it is the most supported version right now and older version might have bugs or conflicts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.