0

When I run M-x shell, I see the following warning (and no shell):

Process shell exited abnormally with code 127

I freshly installed emacs v. 28.2 for osx. I put my stuff in my .emacs file, but I don't think this is causing the problem, as I've tried removing all its contents and I still have this issue. Does anyone have any ideas?

1 Answer 1

0

Emacs isn’t doing anything wrong, it’s just telling you that it ran your shell and the shell exited with an error code. You should read your shell’s documentation to find out what that error code means; it may indicate a problem that you can fix.

4
  • Is there a way I can check where it is looking for my shell application? I can use my shell outside of emacs without problems, so it seems it must be pointing to the wrong location
    – David J.
    Feb 15, 2023 at 23:31
  • 1
    It’s generally specified in shell-file-name, but see the help for shell for more information (C-h f shell <RET>).
    – db48x
    Feb 16, 2023 at 3:01
  • 1
    Have you tried M-x term ?
    – Lee
    Feb 16, 2023 at 17:10
  • 1
    @DavidJ.: So have you checked the exit code 127 of your shell? If you run Bash, try info bash; for other shells, either see its official website or Google it. All in all, you need to know the meaning of the exit code first.
    – shynur
    Feb 17, 2023 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.