0

I moved to a new machine with my identical emacs configuration and all of a sudden S-<right> (which used to work as org-agenda-do-date-later) is responding bound to the command windmove-right (found in windmove-mode-map), which is an autoloaded interactive byte-compiled Lisp function in ‘windmove.el’. How to make this keybinding work again on org-agenda as it is supposed to?

3
  • Is windmove-mode-map a minor-mode map? Minor-mode maps override major-mode maps. See the question I pointed to as a possible duplicate, for what to do when both are minor-mode maps. You can also just unbind that key in windmove-mode-map (i.e., bind it to nil).
    – Drew
    Commented Feb 18, 2023 at 15:49
  • So, if you are in the Org mode agenda and you say C-h c S-<right>, Emacs tells you that the key is bound to windmove-right? And just to make sure: S-<right> means "press the Super key and while keeping it pressed, press the right-arrow key" - is that correct?
    – NickD
    Commented Feb 19, 2023 at 2:37
  • The reason I'm asking is that on the new computer, S-<right> might be hijacked by your desktop environment, so it never gets to Emacs, but it may be doing some "window" action that you are misinterpreting as windmove-right. So I am trying to make sure that we are not chasing phantoms by confirming how exactly you found out that the key is misbound.
    – NickD
    Commented Feb 19, 2023 at 13:27

1 Answer 1

0

I can not yet add a comment, so I wrote an answer. It seams you have enabled windmove-mode and you have called the function windmove-default-keybindings. You can get help as usual with describe-function (C-h f). I have no idea why you only have these mappings on one system and not the other.

Not the answer you're looking for? Browse other questions tagged or ask your own question.