0

I apologize if this is a noob-question, I have little experience with Git. I wanted to set up Magit for my projects, and I followed the "Getting Started" section of the Magit manual by creating a new file in a git repository folder for a project that I had already synched using the GitHub GUI and following the instructions. However, after I try to commit in the Magit-buffer, I get the error:

transient-setup: Wrong type argument: integer-or-marker-p, nil

I saw that the Magit FAQ has a section on problems with committing https://magit.vc/manual/magit/I-am-having-problems-committing.html, but I'm not sure this applies to me. I've configured git in the terminal to use Emacs as an editor, I enabled the emacs systemd-unit, set user variables VISUAL=emacsclient and EDITOR=emacsclient and if I run:

emacsclient -c

in the terminal, it opens a buffer. I installed Magit through Melpa and M-x magit-version prints:

Magit 20230217.2343 [>= 3.3.0.50-git], Git 2.39.2, Emacs 28.2, gnu/linux

What am I missing?

1 Answer 1

1

It was a bug that has been corrected over night.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.