0

I use aquamacs on mac and the latest version apparently maps M-` and M-' to tmm functions (which I don't use and don't care to). This is annoying since these are used for accented letters, in all mac softwares and I normally use it in aquamacs for LaTeX. How can I unset these bindings globally in aquamacs ?

2
  • I don't really know how to properly type the code blocks when it includes the backquote. Any hint would be useful to improve the presentation of my question.
    – SteLab
    Commented Feb 22, 2023 at 13:53
  • You use more than one backquote. This works almost all the time, except for the cases where the "real" backquote is at the beginning or end of the string (as in this case). I cheat in those cases and add an extra space before or after the "real" backquote to separate it from the "quoting" backquotes. It is possible that a zero-width space might be used instead to make it look better, but I can never remember how to get a zero-width space from my keyboard - it doesn't help that I need it once in a blue moon, so I have no muscle memory...
    – NickD
    Commented Feb 22, 2023 at 15:28

1 Answer 1

0

After some digging, I found a working solution to my problem. I added

(global-unset-key (kbd "M-`"))
(global-unset-key (kbd "M-\'"))

to the file:

Library/Preferences/Aquamacs Emacs/Preferences.el

and I can type accents in the usual way.

2
  • After some time working with that, I realize that this does the trick but aquamacs complains with Invalid read syntax: ")". The trouble is that the rest of the startup file does not appear to be executed then.
    – SteLab
    Commented Mar 28, 2023 at 8:02
  • Corrected the answer to remove the error Invalid read syntax: ")".
    – SteLab
    Commented Mar 28, 2023 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.