0

I want to unset all key bindings defined in persp-mode-map and persp-key-map.

As usual, I tried the following but the bindings remain effective sticky. This is a behavior that I have never experienced in other modes unlike persp-mode, because the prefix-command like 'persp-key-map was unused?

(eval-after-load "persp-mode-autoloads" '(setq persp-mode-map (make-sparse-keymap)))
(eval-after-load "persp-mode-autoloads" '(setq persp-key-map (make-sparse-keymap)))

Even if it's stripped down to

(setq persp-mode-map (make-sparse-keymap))

After setting both nil to check, the result is the same even at the moment when the variables are nil comfirmed by describe-variable. Is there any effective method?

3
  • 1
    Please say what you mean by "didn't work". Thx. Have you tried just setting those variables to nil?
    – Drew
    Feb 25, 2023 at 16:32
  • 1
    Put all such clarification into the question. Comments can be deleted at any time. Thx.
    – Drew
    Feb 26, 2023 at 3:30
  • 1
    Fixed the question as you told me. Thanks.
    – roomworoof
    Feb 26, 2023 at 3:53

1 Answer 1

0

I found a solution.

(custom-set-variables
 '(persp-keymap-prefix nil))

The persp-keymap-prefix is described as "The prefix for activating the persp-mode keymap.", defined by defcustom.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.