I recently started encountering a new issue, and I'm not sure why. When opening a Magit status buffer, the diff highlighting doesn't appear until I select a hunk, in which case it appears for just that hunk. When I select another hunk, the highlighting remains.

How can I get the highlighting to always appear?

When first opening status buffer: When first opening status buffer

After selecting a hunk: After selecting a hunk

  • In my environment, it seems that it is working as you wish, highlighted immediately without any setting for the latest version magit (20230317.1751@melpa).
    – roomworoof
    Mar 18 at 3:10
  • Can you check the value of magit-diff-refine-hunk? Try setting it to `all'. Mar 23 at 3:27


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.