I've configured Emacs for my gmx and protonmail accounts using mu4easy. I can receive mails through both accounts and send mails through the gmx-account but if I try to send them through the protonmail-account I get the following error-message:

gnutls.el: (err=[-15] An unexpected TLS packet was received.) boot: (:priority NORMAL:%DUMBFW :hostname :loglevel 0 :min-prime-bits nil :trustfiles (/etc/ssl/certs/ca-certificates.crt /etc/ssl/cert.pem) :crlfiles nil :keylist nil :verify-flags nil :verify-error nil :callbacks nil)
Invalid face attribute :inherit mu4e-contact-face [2 times]
gnutls-negotiate: GnuTLS error: #<process smtpmail>, -15Invalid face attribute :inherit mu4e-contact-face

My protonmail-mbsyncrc-configuration reads

IMAPAccount proton
Port 1143
User ****
PassCmd "gpg -q --for-your-eyes-only --no-tty -d ~/.authinfo.gpg | awk '/machine {print $NF}'"
AuthMechs LOGIN
SSLVersion TLSv1.2
CertificateFile ~/.config/protonmail/bridge/cert.pem    

MaildirStore proton-local
Path ~/mail/proton/
Inbox ~/mail/proton/Inbox
SubFolders Verbatim

IMAPStore proton-remote
Account proton

Channel proton
Far :proton-remote:
Near :proton-local:
Patterns "INBOX" "Archive" "Trash" "Spam" "Drafts" "Sent"
CopyArrivalDate yes
Create Both
Expunge Both
SyncState *

my protonmail-mu4easy-context reads

                      :c-name    "proton"
                      :maildir   "proton"
                      :mail      "****"
                      :smtp      ""
                      :smtp-type ssl
                      :smtp-port 1025)

I've checked that the ports in the mbsyncrc-configuration are the same as in the protonmail-bridge. Any ideas for how to cure this error?

  • 1
    See if the tried options in a somewhat similar thread help you figure out the issue. I'd check the port and smtpmail-stream-type (or analogous for the libs you use) first of all.
    – Y. E.
    Apr 15, 2023 at 9:22
  • 1
    For me the solution was to set (message-send-mail-function . message-send-mail-with-sendmail)
    – Ajned
    Jan 15 at 8:30


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.