0

I have lsp-java set up to use jdtls. It had been working fairly well. For unrelated reasons, I deleted my ~/.m2/repository and then reran mvn install to repopulate the parts of it that I need.

Now when I try to start the LSP server, it fails:

Error opening zip file or JAR manifest missing : /Users/me/.m2/repository/org/projectlombok/lombok/1.18.22/lombok-1.18.22.jar

Process jdtls stderr finished

I know that I had previously been working on project that use Lombok 1.18.22, but the only one I am currently working on uses 1.18.26. I am confident that somewhere, there is a file listing all the projects I've worked on and lsp-java is trying to load all the jars I've needed so that they are available.

I am confident that I could fix this specific problem by downloading that jar, but there could easily be another dozen jars that I don't use any more, and I'd rather not go around building old projects until everything works.

I already tried deleting what looked like cache directories (~/.emacs.d/var/lsp and lsp-java), but that just forced me to reinstall jdtls without resolving the problem.

What do I need to do to clear out that history?

1

1 Answer 1

0

At some point in the past, I had customized lsp-java-vmargs

to include

"-javaagent:/Users/me/.m2/repository/org/projectlombok/lombok/1.18.22/lombok-1.18.22.jar"

That was the source that I was unable to find.

Updating that to 1.18.26 (both the directory and the file name) fixed the problem.

Answering this so that the next person this happens (which could be me when I replace this laptop in a few years) knows to check there, since I had completely forgotten that the variable existed or that I had customized it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.