0

I am using the following format in my org file [[pdf:file_path.pdf][description]] to link to the file_path.pdf file. When I click on the link I expect the pdf file to open. Instead, I get a dialog box with the question No match - create this as a new heading?

I am using Emacs 28.2 on Mac OS. pdf-tools is installed and I can see PDF Tools in the menubar when I open a pdf file. If I change the link to [[docview:file_path.pdf][description]] it opens the pdf in a DocView buffer as expected. My org-pdftools or pdf-tools setting doesn't seem to be working.

I followed the installation instructions from org-pdftools github page. An issue on that github repo suggests using a new package but not sure what I should be trying.


More info:

org-file-apps:

Value:
((auto-mode . emacs)
 ("\\.mm\\'" . default)
 ("\\.x?html?\\'" . default)
 ("\\.pdf\\'" . emacs))
Original value was 
((auto-mode . emacs)
 ("\\.mm\\'" . default)
 ("\\.x?html?\\'" . default)
 ("\\.pdf\\'" . default)

org-file-apps-macos:

Its value is
((remote . emacs)
 (system . "open %s")
 ("ps.gz" . "gv %s")
 ("eps.gz" . "gv %s")
 ("dvi" . "xdvi %s")
 ("fig" . "xfig %s")
 (t . "open %s"))

org-link-parameters: No value for pdf.

2
  • I would uninstall org-pdftools altogether and try the [file:/path/to/file.pdf] link. Does the PDF file get opened? How exactly - in Emacs or with an external application? With the org-file-apps settings above, it should open in Emacs - does it? Next question is: does it open with docview or with pdf-tools? Check the modeline to figure that out. Update your question with your findings. After that, we'll figure out what the next step should be.
    – NickD
    Apr 25, 2023 at 17:47
  • Not using any prefix in the link works-- the pdf file is opened in emacs pdf-tools mode. That's what I need, so it's fine. I didn't get what your suggestion is exactly. I don't want to uninstall and reinstall things without a clear goal. I am baffled by why the documented suggestions are not working, and trying to see if there's something to learn here. PS: Several comments to which I replied seem to have been deleted, so re-editing the question to avoid confusion.
    – vpk
    Apr 25, 2023 at 22:11

1 Answer 1

0

I tried this, and It worked (read the comments in the file).

https://raw.githubusercontent.com/markus1189/org-pdfview/master/org-pdfview.el

Although this is not the optimal solution

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.