1

I modified my init.el-file. I added cursor-modifications and airline-themes. When I want to find a file however, this ugly yellow box occurs. I looked around in my init.el, but I did not find anything suspicious.

Yellow box

Here is my init.el with only the important parts:

;; cursor color
(setq evil-default-cursor       '("DodgerBlue1" box)

    evil-normal-state-cursor  '("#C3A30E" box)
    evil-emacs-state-cursor   '("yellow" box)
    evil-motion-state-cursor  '("SeaGreen1" box)
    evil-insert-state-cursor  '(box)
    evil-visual-state-cursor  '(box)
    evil-replace-state-cursor '(box))

(custom-set-variables
 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 '(airline-cursor-colors nil)
 '(airline-eshell-colors nil)
 '(column-number-mode t)
 '(custom-safe-themes
   '("d80952c58cf1b06d936b1392c38230b74ae1a2a6729594770762dc0779ac66b7" default))
 '(menu-bar-mode nil)
 '(package-selected-packages
   '(powerline-evil airline-themes lsp-java undo-tree ivy lsp-pyright company-jedi company use-package el-search treeview gruvbox-theme eglot))
 '(tool-bar-mode nil)
 '(warning-suppress-types '((emacs) (emacs) (emacs) (emacs) (emacs) (emacs) (emacs))))
(custom-set-faces
 ;; custom-set-faces was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 '(default ((t (:family "Source Code Pro" :foundry "ADBO" :slant normal :weight normal :height 100 :width normal)))))

;;evil
(add-to-list 'load-path "~/.emacs.d/evil/")
(require 'evil)
(evil-mode 1)


;;emacs theme
(load-theme 'gruvbox-dark-hard t)

;;emacs airline
(require 'airline-themes)
;; (load-theme 'airline-light t)
(load-theme 'airline-base16_gruvbox_dark_hard t)

There are other possible costumizations with "M-x customize: airline". But I couldn't find any setting to change that. Thanks for any help in advance.

Airline customization!

8
  • Did you try bisecting your init.el file? I mean, try removing one piece of configuration at the time and see what happens when you restart Emacs. May 17, 2023 at 11:07
  • @ManuelUberti Well when I remove any of the emacs-state... I get an error. But I didn't try the ones where it said nil, because this is pointless anyway.. May 17, 2023 at 11:10
  • 1
    What error did you get? You can also try installing airline-themes in emacs -Q to avoid clashes with your existing setup, and see if the colour you don't like appear there as well. If it's there, then it's something related to the theme and you may have to look for the right face to change. May 17, 2023 at 11:14
  • 1
    I think M-x customize-face RET minibuffer-prompt RET should get you started. May 17, 2023 at 14:51
  • 1
    For further reference, C-h r m Face Customization RET should give you more information about setting faces in Emacs. May 17, 2023 at 14:53

1 Answer 1

1

From a cursory look at the source code of the theme you are using, I see it changes minibuffer-prompt (See: https://github.com/AnthonyDiGirolamo/airline-themes/blob/master/airline-themes.el#L485).

You can move the cursor on the minibuffer prompt and use M-x describe-face RET to see the face in use. That's how I discovered minibuffer-prompt was involved.

You can then proceed with M-x customize-face RET minibuffer-prompt RET and remove the background or tweak it to whatever you prefer. See C-h r m Face Customization RET for further details about customizing faces.

1
  • I now have a way to colorize it in a different way. But can I remove it completely? When I uncheck the boxes, they'll be there still after I restart emacs. Probably this face is just required? (and I made sure to save the settings) I should probably try and get the background to match my color scheme. That way, it won't be visible and I got what I wanted.. EDIT: It looks decent enough. Thanks for the help! :) May 17, 2023 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.