0

I'm getting the following error from tramp (v2.6.0.29.1) when I attempt /-:|sudo:: and tramp-save-ad-hoc-proxies is true. I'm running this in a docker container in WSL2. I've tested it with my home directory both inside the docker container and on Windows. It's the same error either way. I also tried allowing it to put customizations in my init.el. I tried deleting the tramp and customizations files. I tried running check-parens on the customizations file it generates.

Depending on how I have things configured, it can become almost completely unresponsive. If I hit C-g a few times and wait 10-20 seconds, it will usually come back. Without tramp-save-ad-hoc-proxies, it seems to work fine. Any ideas?

Saving file /mnt/home/goldfita/.emacs.d/custom.el...
Wrote /mnt/home/goldfita/.emacs.d/custom.el
End of file during parsing: End of file during parsing, 
Scan error: "Scan error", "Containing expression ends prematurely XXX XXX"
Scan error: ...
6
  • What is your default method? When I run on my Fedora laptop emacs -Q -l tramp --eval '(setq tramp-save-ad-hoc-proxies t)' '/-:|sudo::' I get the error message tramp-error: Method ‘scp’ is not supported for multi-hops.. May 23, 2023 at 14:30
  • I'm using ssh. I think I tried scp initially and it wasn't working, probably for the reason you just mentioned.
    – Todd
    May 23, 2023 at 23:34
  • I see. Perhaps there's something odd in your init file. Please call emacs -Q --eval '(setq tramp-default-method "ssh" tramp-save-ad-hoc-proxies t)' '/-:|sudo::' - this works for me on Fedora. May 24, 2023 at 8:18
  • I had to use '/-:192.168.2.6|sudo::'. It's refusing to write the customizations. Setting 'tramp-default-proxies-alist' temporarily since "emacs -q" would overwrite customizations. I tried renaming my init.el, but I still get the same message.
    – Todd
    May 24, 2023 at 14:40
  • No, that's expected. -Q doesn't touch the init files. I've asked you to run this command in order to know whether there is a general. May 24, 2023 at 17:45

1 Answer 1

0

It turned out to be a Tramp issue. Fixed in Tramp 2.6.0.5 on GNU ELPA as well as in the upcoming Emacs 29.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.