0

Using emacs 28.2 (build 2) on MacOS 12.6.5 on 16” M1 2021.

About six months ago, I updated emacs. Now all my old files have their higher-value characters spelled-out in octal format. For example:

What I see: I meet with Pena\234\364\362\371s sub, Georgette, at 1400.

What I should see: I meet with Pena’s sub, Georgette, at 1400.

Yes, they are valid octal characters (i.e., when I do C-x = they show as themselves). The coding system info on the mode-line is -UUU:-.

I’ve tried visiting the file using various coding systems via C-x <RET> r before opening the file in Dired. Nothing has worked.

1 Answer 1

1

The UUU: in the modeline indicates that Emacs opened the buffer expecting to find UTF-8 encoded text with Unix–style line endings. UTF-8 is generally the best choice for text today, so this is good.

If \234\364\362\371 is actually what you see, then the file is not actually in UTF-8. Specifically, the first byte (\234) looks like a continuation byte, but it should only come after a byte that starts a multi–byte character. It clearly doesn’t, which is an error.

Similarly, the other three bytes each look like the start of a multi–byte character, but none of them are followed by continuation characters. Thus all four bytes are considered to be errors and Emacs displays them accordingly.

I don’t recognize the coding system the file is in, but if you want to guess then you could use revert-buffer-with-coding-system to reopen the file with a different encoding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.