0

So today I installed a dashboard for emacs with M-x package-install RET dashboard. It works perfectly fine. I made some nice customization and it looks great! But by default, there are some messages (at random) that I don't like (at the bottom of the screen). These in particular are annoying: "Happy coding", "Free as free speech, free as free Beer". And they still show up. So I was wondering how to remove them permanently.

Here is the source code in `~/.emacs.elpa/dashboard-20230512.1839

/dashboard-widgets.el`:
(defcustom dashboard-footer-messages
  '("The one true editor, Emacs!"
    "Who the hell uses VIM anyway? Go Evil!"
    "Free as free speech, free as free Beer"
    "Happy coding!"
    "Vi Vi Vi, the editor of the beast"
    "Welcome to the church of Emacs"
    "While any text editor can save your files, only Emacs can save your soul"
    "I showed you my source code, pls respond")
  "A list of messages, one of which dashboard chooses to display."
  :type 'list
  :group 'dashboard)

            |
            |     (Here my personal customization)
            |
            ⊻

(defcustom dashboard-footer-messages
  '("Who the hell uses VIM anyway? Go Evil!"
    "Welcome to the church of Emacs"
    "While any text editor can save your files, only Emacs can save your soul"
  "A list of messages, one of which dashboard chooses to display."
  :type 'list
  :group 'dashboard)

As you can see, I already got rid of the sentences that I didn't like. Only these are the ones I look for when I boot emacs. But still, sometimes these other sentences are displayed. I did some digging and found this: M-x byte-compile-file. But that didn't work either. Here is my error message: end of file during parsing. Thanks for any help in advance :^).

To clarity further: I want to get rid of sentences I already deleted from the elpa folder:

enter image description here

EDIT: As it turns out, I just overlooked the options. It is really customizable using the normal UI setting. It was at the bottom and I thought the footer above was the only option for that. Now I have what I was looking for, right? But my question still remains. When I edit the source code directly from the elpa folder, why do my changes not apply?

enter image description here

10
  • "end of file during parsing" is because you have two opening parens and only one close paren. The rest of your question isn't clear (to me) at all. Just what is it that you want to ask?
    – Drew
    Jun 3, 2023 at 19:58
  • @Drew Well ok. So I installed the package and with it, there are sentences that get displayed at the bottom of the screen. I already removed them from the code snippet above. These sentences are also included: "Happy coding", "Free as free speech, free as free Beer". And they still show up. So I was wondering how to remove them permanently. You can visit the github repo I linked. There you can see the source file yourself. What exactly do you not understand about my question? Jun 3, 2023 at 20:00
  • Please put all relevant info in the question itself, not in a comment.
    – Drew
    Jun 3, 2023 at 20:28
  • @Drew Hmm ok. Contentual, I really didn't add anything. I hope you understand my question now? Jun 3, 2023 at 20:32
  • 1
    Once you make changes to the source code of a package you have downloaded, you might still have to byte-compile the package (it depends on how the package is loaded in the first place: if there are byte-compiled versions of the files, then they have to be re-compiled in order to reflect the updated source versions). And once you have byte-compiled the package, you still have to reload the re-compiled files into Emacs in order to have Emacs use the new version. One way to do that is to restart Emacs. If you still do not see the changes, then you have done something wrong.
    – NickD
    Jun 4, 2023 at 10:06

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.