0

whenever I run this command (shell-command "chatgpt install &") my input characters gets repeated like this:

1> hi hi

Hello! How can I assist you today?

2> hi again hhii aaggaaiinn

Hello! Welcome back. How can I help you today?

3> hi again again hhhiii aaagggaaaiiinnn aaagggaaaiiinnn

Hello once again! I'm here to assist you. What can I do for you this time?

4> hi again again again hhhhiiii aaaaggggaaaaiiiinnnn
aaaaggggaaaaiiiinnnn aaaaggggaaaaiiiinnnn

when I run the same command from vterm the input does not get repeated at all.

I tried: run async-shell-command directly instead of shell-command

giving parameters to shell-command for output-buffer and error-buffer

setting comint-process-echoes to t

non of those worked.

emacs version: GNU Emacs 29.0.92 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.20, cairo version 1.16.0) of 2023-06-25

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.