0

Linux Mint 21

Emacs 27.1

On my PC are plugging 3 monitors.

So when I run Emacs in GUI mode and then run command M-x make-frame-on-monitor

I get the next result:

enter image description here

I select desire monitor and Emacs open new frame in selected monitor.

Nice.

Now I run Emacs in text mode like this: emacs -nw and then run command M-x make-frame-on-monitor, I get the next result:

enter image description here

As you can see I can't select another monitor. How I can do this in text mode?

2
  • n.b. You can open new frames from a terminal frame, but only one of them can be displayed in the terminal at a time. You can see in the mode line which frame is currently being displayed (F1, F2, etc).
    – phils
    Jul 16, 2023 at 11:14
  • @phils whoa! you taught me something, you should make that comment into a complete answer (I guess you have to add that "monitors" and "displays" don't make sense as a concept in terminal, but that frames still do)
    – Trevoke
    Jul 18, 2023 at 18:46

1 Answer 1

2

You’re running Emacs inside of a terminal emulator. Historical terminals only ever had one monitor, and so terminal emulators only provide a single window to the applications running inside them. Thus there is no way for Emacs to do it.

The closest you can get is to run M-x server-start, then open another copy of the terminal emulator and run emacsclient in it. This is a lot more complicated than merely opening a new frame in the Emacs GUI, but it has a similar effect.

1
  • Another option is make-frame-on-display, but then you need to move the frame to the right monitor,
    – rpluim
    Jul 17, 2023 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.