0

The problem may be because I am doing this via Tramp, connecting to an Amazon ec2 instance where gdb is installed.

I had Emacs 28.2, and now I've upgraded to 29.1 and the same problem occurs. If I have gdb-many-windows on, and I start a debugging session, after a few steps, it freezes, and I observe a spike in Emacs' CPU usage. If I turn off gdb-many-windows, it works fine.

I'm on a 2021 MacBook Pro, M1 Pro Chip, 16GB, running macOS Ventura 13.4.1 (c).

When I issue M-x gdb to start, Emacs offers to run gdb with -i=mi. I tried opening with that setting and without it; without it, nothing even gets off the ground; it just fails right away.

Thanks for any help you can provide!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.