1

when emacs -nw opens a file from term (gnome-terminal, alacritty), there are extra chars like [I

If I move the mouse in and out of the terminal, we get more of these [I[I[I

(the brackets can be paired when using smartparens)

I resolved this to some extent with -Q and by removing for smartparens
(sp-pair "[" "]" :wrap "M-[")

from reading a post where someone had discovered that was the culprit.

however, running nnn filemanager, sometimes requires moving to the $EDITOR which is emacs -nw and neither of the above has any effect and I'm getting at the beginning.:
65;7202;1c

If I set EDITOR=mg, it opens cleanly with no issues.

I would like to know:

  1. what is causing this behavior
  2. what those chars are (some ascii codes?)
  3. how to stop it
4
  • 1
    What is TERM set to? what happens when you use xterm?
    – nega
    Commented Aug 16, 2023 at 15:13
  • TERM=xterm-256color and xterm does NOT cause the same problem. could it be because the color setting on TERM applies properly to xterm, but not gnome-terminal? Commented Aug 18, 2023 at 21:58
  • yeah, sounds like a combination of terminal and window manager. a bit surprised about alacritty misbehaving. i really only do Linux remotely anymore, so my best advice is 1) make sure TERM=xterm-256color is set, and use an "old" terminal (ie. xterm/aterm/rxvt/urxvt). i've never found the VTE based terminals to be any good
    – nega
    Commented Aug 19, 2023 at 3:54
  • for what it's worth, i dropped alacritty, and kitty. both were good, but there was too much "special casing" w/ various apps. now if i have a choice my descending choice is footsturxvtxterm
    – nega
    Commented Aug 19, 2023 at 4:02

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.