4

I've just updated to Emacs 29, but running (pixel-scroll-precision-mode 1), even with emacs -Q, doesn't have any visible effect for me. (default-value 'pixel-scroll-precision-mode) evaluates to t but scrolling is still instant.

I'm running 29.1 built with XInput 2 support (system-configuration-options pasted below) under X, and AFAIK there's nothing else that should be necessary for this to work. Any idea what gives?

I don't think it should be relevant, but I'm running i3 and I have Emacs installed through Nix.

system-configuration-options: "--prefix=/nix/store/zbh69bbb8c13w5rrpbhp9rsa7aax4d42-emacs-29.1 --disable-build-details --with-modules --with-x-toolkit=lucid --with-xft --with-cairo --with-native-compilation --with-tree-sitter --with-xinput2"

5
  • Is there anything unusual about your mouse/wheel hardware or config?
    – phils
    Commented Aug 21, 2023 at 0:10
  • No, AFAIK... consistent behaviour for both mouse and trackpad, neither of which I remember ever needing any special configuration or behaving badly with other programs.
    – wohanley
    Commented Aug 21, 2023 at 1:03
  • Same on macOS. Didn’t spend much time looking into it though. Might be something that changed since RC1 and release. Don’t know
    – David
    Commented Aug 21, 2023 at 4:35
  • If you think some user option "has no effect" then M-x report-emacs-bug, giving a recipe and specifying what you mean by "has no effect".
    – Drew
    Commented Aug 21, 2023 at 5:30
  • @Drew Sorry, I'm finding it hard to think of more explanation of "no effect". I can't see any difference in scrolling with pixel-scroll-precision-mode enabled or disabled, scrolling is instant either way. Anyway, I'm not confident that there is a bug here; I think it's more likely that I'm doing something silly that someone here might be able to point out. If that isn't the case, eventually I'll call it a bug.
    – wohanley
    Commented Aug 21, 2023 at 6:01

2 Answers 2

1

oldosfan (a.k.a. Po Lu, the author of pixel-scroll-precision-mode) (quoted from here):

如果滚轮不支持像素滚动,请不要报告 bug,这种滚轮我不会支持。

Translation: If the scroll wheel does not support pixel scrolling, please do not report bugs, as this type of scroll wheel will not be supported.

For users using macOS or MS-Windows, you can download SmoothScroll to simulate pixel scrolling. I believe there is similar software for GNU/Linux as well.


OP has reported the question as bug#65514.

3
  • Here is a pixel scrolling demo (using SmoothScroll on MS-Windows): <github.com/shynur/.emacs.d/issues/1#issuecomment-1671844378>
    – shynur
    Commented Aug 21, 2023 at 4:42
  • I don't think my scroll wheel is the cause, because scrolling with the touchpad doesn't work either. Or am I misunderstanding what you mean?
    – wohanley
    Commented Aug 21, 2023 at 5:51
  • @wohanley: If you want to report a bug, report it. Or, before doing so, you can try some similar software I mentioned earlier.
    – shynur
    Commented Aug 21, 2023 at 8:41
1

This actually was because of Nix - my Nix-installed Emacs wasn't linking my system libXi. It was easier for me to just stop using Nix to manage Emacs than to fix this, so I never found a real solution.

See Po Lu's response on the mailing list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.