0

Clicking the echo area causes Emacs to switch to the *Messages* buffer.

I hate this behavior, because the only time I click the echo area is on accident, whereupon it wastes time and breaks train of thought as I have to interrupt what I was trying to do with burying the messages buffer.

How do I disable it, so that clicking the echo area does nothing? (I know that mouse clicks are bound just like any other key, but I don't know what keymap to use?

And since the echo area alternates between showing the contents of *Minibuf-0*, *Echo Area 0*, and *Echo Area 1* buffers, the latter two of which can be deleted and get automatically recreated, I don't know if it needs to be done in some mode or minibuffer setup hook?)

1 Answer 1

4

STEP 1: Type C-h k and then left mouse click inside the echo area.

STEP 2: Read through the *Help* buffer and observe the message that reads:

<mouse-1> at that spot runs the command view-echo-area-messages (found
in minibuffer-inactive-mode-map), which is an interactive
byte-compiled Lisp function in ‘help.el’.

STEP 3: Redefine or disable the offending keyboard shortcut. To make sure that you have found the correct mode-map, it might be helpful to set up a message such as:

(define-key minibuffer-inactive-mode-map [mouse-1]
   (lambda () (interactive) (message "hello-world")))

STEP 4: Then, after verifying the above-mentioned definition works as advertised, go ahead and change the function parameter to either nil or 'ignore:

(define-key minibuffer-inactive-mode-map [mouse-1] nil)
1
  • Big thanks! I wrongly assumed that in this one specific case, describe-key wouldn't work, since I'm used to it needing to run "in" the buffer that has the binding.
    – mtraceur
    Aug 27, 2023 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.