1

When I deselect a buffer, an empty rectangle is shown in the cursor position.

The following image shows the cursor in a buffer which is not the selected one.

enter image description here

The following image shows the cursor in the selected buffer.

enter image description here

How to make Emacs keep the empty rectangle even when the buffer is selected?

The reason I want to do this is because I'm using Emacs to correct OCR text and having a white rectangle makes it difficult for my eyes to differentiate that character in comparison to other characters. In the image below, you can see that, in the buffer below, the first character is shown with a different background color because of the cursor. I wish that the cursor were shown using the same style as if the buffer is not selected. (one simple solution would be to just deselect the buffer, but I cannot do that as I'm moving the cursor around that buffer to correct the incorrect OCRed characters).

enter image description here

1 Answer 1

4

Set or customize the cursor-type to hollow.

(setq cursor-type 'hollow)

Or you might prefer to set it to any of the other options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.